Обновяване на системата ДжумлаМетодите за ъпгрейд на системата са два.

1. Автоматичен метод.

Поддръжката на Джумла 1.5 беше официално прекратена, това разбира се не означава че сайтът ви ще спре да работи, напротив, той ще продължи да функционира. Спирането на поддръжката означава, че разработчиците няма да пускат вече нови версии на 1.5 в които има включени поправки на основата. Това е и причината поради която се препоръчва миграция към по-новата версия.

Миграцията от версия 2.5 до която и да е трета версия е проста задача тъй като процеса е опростен за по-новите версии на системата. За съжаление промяната от 1.5 към последната версия не е чак толкова лесна. За радост на всички собственици на сайтове обаче, съществуват няколко много добри модула които да свършат работата вместо вас, а именно jUpgrade и SP Upgrade.

Пред Вас стои изборът да преминете на версия 2.5 или направо на трета. И двата модула разполагат с тези две опции. Моля погледнете документацията им преди да престъпите към обновяването.

Ако всички модули и компоненти на сайта ви са съвместими с Джумла 3.0, мигрирайте направо към нея.

Ако търсите най-стабилната версия и ако планирате да използвате много модули, то по-добрият вариант за вас е 2.5.

2. Ръчно обновяване.

Инсталирайте Akeeba Backup във версия 1.5 и направете архив.
Използвайте някой модул с който да еспортирате всички потребители и статии.
Инсталирайте версия 2.5 или 3.х в поддиректория.
Импортирайте информацията от 1.5 във новата инсталация чрез J2XML
Инсталирайте Akeeba Backup на новата инсталация и направете архив
Създайте менютата и инсталирайте нужните компоненти и модули
! Правете архиви на всяка стъпка.
Когато сте преместили всичко изтрийте основната директория и преместете новата инсталация в основната папка.